Add a Watermark to PDF - Poor Image Quality

Am using the Add a Watermark to PDF function and the imprinted image quality has a very low pixel count resulting in a low quality image. Any idea or options to improve this so the watermark imprint is the same quality as the original immage?

Hello @Cam0908,

We added a task to improve the quality of watermark images to our roadmap. I'll notify you once it's released. Thanks for waiting!

Best regards,
Petr
Plumsail team

Is there any update on this feature?

Hello @sphilson,

Yes, we implemented the feature. The best image quality is now applied by default.

Best regards,
Petr
Plumsail team

I am using Power Automate to add the watermark. and it is still showing poor image quality. are there anything I can do to make it better? Thanks.

Hi @Doris_NIPO_Software,

Could you check if the source watermark image has a good quality?

If it's ok, please share your PDF sample, the watermark image and a screenshot with the action and I'll try to reproduce the issue and fix it if it's confirmed.

You can share the files to [email protected] with a reference to the thread.

best regards,
Petr
Plumsail team

I an having similar issue . The watermark is in poor quality . Is there any solution for retaining image quality?

Hi @awadIssa67,

Could you share a pdf sample, the watermark in original quality and the result pdf file where the watermark quality is decreased?

We'll investigate the case and improve it if confirmed.

You can share the files to [email protected] with a reference to the thread.

Best regards,
Petr
Plumsail team