Auto routing Form Sets to SharePoint Group doesn't working


I've tried to route the form to my department group members using Form Sets but does not working as per what I have read in

After save the form and open from browser, I still view the default form even though I've excluded other groups and only select 1 group.

Did I missing any settings? Please help me.

Hello @noorshahida88,

Please try to uncheck 'Limited access system group' in 'Excluding the selected groups' section. As this might be the cause of routing issue.


@mnikitina, I have untick the group from excluding section and saved but still same.


The Form Sets routing works so, that if the user is a member of the excluded group, the form set will not open for him.

So please make sure you are not a member of any selected group under 'Excluding the selected groups' section.

Thank you @mnikitina, now it is working perfectly after I untick group whereby my name was in there.

Regarding the group listing in the Form Set setting, why I cannot view other SharePoint groups that I have created? For example I have created IS&T HOD and Information System (IS) which I would like to create separate Form Set for this group, but there is no way I able to add this group now.


Form Sets use Site Groups.

To see site groups, go to the root team site. Click on Gear in the top right of the screen >> Site Permissions.


@mnikitina i know how to check on group listing for the site which I have created already. But I cannot see from the Form Set, how many groups can be view from it? Only 10?



The list of groups available in Form set pulls from the root site. So if you've created a group in the subsite [domain name]/sites/[root site name]/[subsite name] - it won't be listed in Form Set settings.

Please do the following:

  1. Go to the root site [domain name]/sites/[root site name]/, for example,
  2. Open Site Permissions. You will see the same list of the groups that you have in Form set settings.
  3. Create any new group.
  4. Reconnect the Plumsail Forms Designer. And you will see the newly created group in Form set settings.

@mnikitina, now I understand how the Form Set works :sweat_smile:

I don't have any issue to see other groups created before because those groups being assigned to list libraries which are created to that site.

While this issue happened due to the list is created under sub-site, so I need to grant permission for this group at the site level too.

Issue solved :+1:

1 Like