Cannot publish Workflow - Cannot create unknown type '{clr-namespace:Plumsail.ActionsPack} DeleteAllPermissionsFromItem


I can not publish Workflow which contains Plumsail Workflow Actions.
I have tried to reactivate feature (it worked with PowerShell), and

Workflow Error says:
"Microsoft.Workflow.Client.ActivityValidationException: Workflow XAML failed validation due to the following errors:
Cannot create unknown type '{clr-namespace:Plumsail.ActionsPack}DeleteAllPermissionsFromItem'. HTTP headers received from the server - ActivityId: 9a455cdd-1985-437f-af1e-ec0d7b442a70. NodeId: SomeServerName. Scope: /SharePoint/default/2acc9c9b-5065-430b-942b-423fe7663534/6e2db9b5-4e1c-40a3-ae88-7acba019e0c8. Client ActivityId : 9cee0ea0-93c0-7024-e723-56e4e2739545. ---> System.Net.WebEx"
I have also verified license on this Site Collection and site itself:
"License information: License type - Full
Product version: 2021.06.2"
SP Designer cleared and refreshed.
Normal Workflows are working fine.

Any ideas?

Additional info - it happened after migration from DEV to PROD server.

I have found something interesting. I missed it.
In the error the NodeId is:

which is obviously wrong. It should be prod server.

Where and what shall I do to have it properly set?

Hello! I would ask you to repeat the performed steps in the order below and inform me about the result (ensure that you run all commands on the proper server):

  1. Disable the WAP feature (do not miss the "force" flag):
    Disable-SPFeature -identity 22bb2cee-2403-4b7c-818e-9078b11a218b -URL https://somesite -force
  2. Enable it:
    Enable-SPFeature -identity 22bb2cee-2403-4b7c-818e-9078b11a218b -URL https://somesite -force
  3. Clear the SharePoint Designer cache (the instruction).
  4. Disable the feature again:
    Disable-SPFeature -identity 22bb2cee-2403-4b7c-818e-9078b11a218b -URL https://somesite -force
  5. In SharePoint Designer, open "All Files" > "Workflows" and delete all folders with the "WFPack_" prefix.
  6. Then, enable the feature again:
    Enable-SPFeature -identity 22bb2cee-2403-4b7c-818e-9078b11a218b -URL https://somesite -force
  7. Clear the SharePoint Designer cache again.
  8. Create a new workflow with a Plumsail action and try to publish it.

i had the same problem and tried exactly executing the points in order as listed.

Now all the Folders with "WFPack_" are gone and even after enabling the feature again and clearing the cache it does not appear again and


and now everytime i try to open a workflow this appears which did not happen before.


creating a new workflow works, but all the plumsail actions are missing. even with the feature activated at site collection level and the plumsail auth service is also acitvated on the server.

Nevermind they are back. had to install the Action Pack from scratch.

1 Like