Cross-site lookup bug

Today, I went into an issue when I tried to use the cross-site lookup field (fd.control) to choose from the cities field. Let's say we have a source list with these cities on the different site collection: Brno, Praha, Ostrava, and Bratislava are the cities.
When I put the Lookup field on the canvas in New Form and set up the Source list, and choose the field "City", it all goes OK.

When I go to NewForm (the form which is having the lookup field linked to the data source) and choose "Brno", and hit "Save", the form is saved, but in the list view, I cannot see the value.

As you can see in the attachment - you can see no values, but when I want to filter on this field, you can see, the values are there.

When I hit the list item to see the details (DispForm), I can see these chosen values from NewForm based on Lookup.

In the end, when I hit the save button on "NewForm" in Plumsail forms and close the program and reopen it, the Lookup (fd.control("Field1")) is missing and the custom JS I made is also missing. What happens? :slight_smile:

If you need more information, I am here to help.

Thank you,

Dear @Stepan,
Can you check browser's console when no value is visible? There might be an error there to give us a clue as to what goes on.

Hi @Nikita_Kurguzov ,
no errors.

In Classic Design of SharePoint - it can be seen.

  1. I also tried different view - did not help
  2. Tried to edit the form and rename the field (One line text field) with different value - did not help

I tried to create a different List with the same vLookup and the same single line of text to copy the chosen value from vLookup t this field and it works. I have done the same steps as before. I will try to recreate the List of items and edit this thread with new data.

So, I deleted the list of items and recreated it. I have not deleted the configuration for Plumsail Forms (NewForm/EditForm/DispForm). I have left the configuration as it was. Not, it's working. I do not know, where the problem was. It's a mystery.

Dear @Stepan,
So, it works now? The List View uses field customizers to display values properly, perhaps, it was broken in the previous List View for some reason.

I do not understand why it has begun working after the recreation of the list. But yes, it works now.

1 Like