Custom forms are not saved


#1

When I’m trying to save customized form for the SharePoint Online list via Plumsail Form 1.0.1 there’s always following error message “Microsoft.SharePoint.Client.ServerException: The column CanvasContent1 doesn’t exist” (see the screenshot attached).

But in my SharePoint list I have never created or added the column with the same internal or display name.
So I suppose that it’s the custom field that might be added by Plumsail Form.

Could you please provide me with any information regarding it can be solved?

P.S. The installation was done following the instructions (https://account.plumsail.com/forms/intro), the sppkg file is deployed to the all site collections and the trial license for the tenant is activated since the last week.


#2

Thank you for the issue report! May I ask you to provide temporary access to your site? If yes, share access with [email protected]. We need at least site collection admin permission. If not, try to create a new site or site collection, activate Site Pages feature and customize a form of a new list.


#3

Hi again!
We’ve added activation of the Site Pages feature into the app. Just restart the designer and it will be upgraded automatically. Next, reset the form, design it again and save (if you have a complex form, just export it into a file before resetting). Please let us know the result.


#4

Hello Dmitry,

Unfortunatelly I cannot provide you with the temporary site collection admin access to our site.

But, I’ve tried to apply the steps from your last message (restart Plumsail Forms, reset list form and create the new one).
This time the error is different:

P.S. Btw, is it normal that after restarting Plumsail Forms the version shown has not changed - it’s still 1.0.1?


#5

Please ensure that Site Pages feature is activated now: go to the Site settings -> Manage site features -> Site Pages. If not, please activate it manually and try again. Possibly, you just need to wait a bit until those columns appear in the Site Pages library (the columns are added by the Site Pages feature).

If it does not help, may I ask you to create a new site and try to design a form there?

A minor version is not displayed in the designer, that’s why it’s still 1.0.1.


#6

Dmitry,

After manual activation of the “Site Pages” feature it works henceforth


#7

I have this error when trying to save a file that i have imported. The reason for this is that a different user created the from and I do not want to re-create the same form. When I import it, I get the below error