Fill in PDF Form Flow Run Failed


#1

I’m trying to use the Fill in PDF Form action, but am receiving the following error message:

Error
Action ‘Fill_in_PDF_Form_3’ failed

Error Details
After parsing a value an unexpected character was encountered: E. Path ‘NotRemediateComments’, line 21, position 38.

The form was created in Acrobat Pro and I’m including a screen shot below of the flow. Any help would be much appreciated. Thanks.


#2

Hello @AlexK,

There seems to be an issue with this value:
‘NotRemediateComments’

2019-06-05_11-27-37

  1. Please try to hard-code or remove the value from the JSON and run the flow again to isolate the issue
  2. If it works fine without the value, check the parameter, possibly there is some incorrect symbol and share with me the results.

Best regards,
Petr Bushuev
Plumsail Team


#3

Hi Petr, thanks for the quick reply. The flow began working and the form is filled in successfully when I removed that value, but I’m now facing a new problem with adding that value to the form.

I’ll try to explain what I see happening as best I can and I provided screen shots below. This flow is triggered when an item is created on a sharepoint list and this specific value is coming from a list field called ‘supervisor comments’. When an item is initially created, that field is empty, but after an approval further down the flow, the ‘supervisor comments’ field is updated based on the approval response comments.


Capture%202

That part of my flow works. After the item is updated, my flow then proceeds to a condition based on the approval outcome. When the flow directs to the “If no” condition, there a couple steps before the Fill in PDF Form action where I’m experiencing the issue.


The “NotEscalateComments” field of my form is where I want to drop the ‘Supervisor Comments’ value, however when I search for ‘supervisor comments’ among my available dynamic content, it is only showing me values I can pull from item action steps that occur before the approval is made. When I use one of those values, it results in an empty field in the form.

Capture%205

What I’m not seeing in my dynamic content is the ‘supervisor comments’ value under the ‘Update item to include Supervisor decision and comments’ action step. I also tried adding the ‘Response Comments’ from the approval, but that caused the ‘Fill in PDF Form’ action to fall under an ‘Apply to each’ action, which caused another error.

I hope that explains the issue. If not, please let me know how I can better clarify and thanks again for your help.


#4

Hi Petr, problem solved. It seemed to have do with the format of the ‘supervisor comments’ field in the SharePoint list. I changed it to a ‘single line text’ and plain text, and I’m now able to pull in the comments.

Thanks again for the help.