Form embedded as webpart in Sharepoint Site on Teams

I have a "New" form in a sharepoint site which works great. My problem is with a Person Picker field doesn't allow typing in it when the Page is inside Miscrosoft Teams. Has anyone witnessed this? Screeshots are

  1. In a web browser
  2. In Teams Room

So I figured (I think) what the issue was. I was using Javascript to clear that field on Render and after removing that it worked as designed.

Hello @IT.Joe,

Could you please share the code that you've used to clear the field.

What browser are you using?

fd.spRendered(function() {
fd.field('RespondTo').clear()

It works fine on all browsers but where it breaks is when it's in MS Terams. I added it as both a Sharepoint Page (I created a page with a webpart of the New form) and also added it as Webpage and both acted the same. It prevents you from typing in the field.

Hello @IT.Joe,

Is it possible to provide us temporary access to the site and the form to troubleshoot the issue?

Please email us at [email protected].

I had removed it from the Form since it wasn't working. I just added it back in and put the Clear code back in and it worked as designed. There was an update to Plumsail that I had installed after I removed the field so maybe whatever was wrong was fixed in the update. I will let you know if it happens again but for now it seems to be working.

1 Like