Form Set routing based on group membership

This is a two-part question.

  1. It appears only default form sets open in the forms panel (Modern View). Non-default form sets restricted to certain SharePoint groups redirects to a new page even with the Form Panel settings enabled. Is there any way I can set an item to open in the forms panel for all form sets?

  2. When creating a new form set, I am only able to select SharePoint groups where the group type is ‘SharePoint Group’. We have several groups in SharePoint online which takes its membership from the domain group in AD. Currently we maintain two groups in SharePoint Online when we want to restrict users to form sets. Are there any plans to allow the ‘Domain Group’ type to be selected with Form Sets?

Dear @Andre,

We are researching your issue, I’ll reply to you soon.

Dear @Andre,

  1. Please check the version of the application in the app catalog and update it if it’s outdated: https://plumsail.com/docs/forms-sp/general/version-history.html

Then open both form sets, set the appropriate panel mode and resave both form sets.

  1. Unfortunately, the AD groups are not supported.

Hi @AlexZver

Thank you for the feedback. The application catalogue was already on version 1.0.6.0 but I nontheless downloaded the latest file and updated the app catalogue again. When I opened Plumsail Forms today it updated to version 1.3.5.

I then opened both form sets, changed the panel modes and saved all again. The non-default froms still did not open in the panel. I checked the catalogue upgrade documentation and noticed that I now had a new redirect2.aspx (in addition to redirect.aspx) in Site Pages - PlumsailForms. I deleted both and saved one of the forms again. This recreated the redirect2.aspx file.

After all this the non-default forms still do not open in the panel while default forms open in the panel.

Dear @Andre,

I’m sorry, I can’t reproduce your issue. Most probably the cause is the scripts are not loaded in time please try to wait a little longer before opening the item from the List view.

If it doesn’t help, could you provide temporary access to the form so I can research your issue more closely?

You can either share a site with an external user ([email protected]): https://docs.microsoft.com/en-us/sharepoint/external-sharing-overview

Or provide credentials of one of the existing users - then you can change the password.

Hi @AlexZver
I shared the site with you and included a link to the relevant list.

Dear @Andre,

I’m sorry, I’ve tried to access your site but it seems I don’t have a permission. Could you please try again?

Hi @AlexZver
Please try again. I updated the list permissions.

Dear @Andre,

I've reproduced your issue, please try to apply the panel mode to the corresponding form set, this should help:

Hi @AlexZver
It is still redirecting for non-default form sets. Below is the settings I applied.

image

Hi @AlexZver
Some further testing on my side:
I created a new list and saved new Plumsail forms for each of the default forms. I enabled the forms panel. In this instance I do not have separate forms applied to any group membership - just using defaults here. When I edit or view an item in the list it redirects to a new page. If I log in as another user, using the same browser on the same device, the forms open in the panel.
It seems to me this issue possibly relates to my specific user account. Any idea what is causing this?

Dear @Andre,

Very strange behavior. We need to take a closer look at this, so I have to ask you to provide your credentials by my email. ( [email protected]) Then you can change your password.

Hi @AlexZver
I did email you the credentials as requested. Not sure if you received the email.

Dear @Andre,

I received your credentials and reproduced your issue, we are working on it.

Dear @Andre,

The issue was fixed, please completely clear the browser cache first.

Hi @AlexZver
I can confirm the issue is resolved.
Thank you