List of SharePoint Fields incomplete : some fields are missing [SOLVED]


I have opened a custom list with the Plumsail Forms (1.5.6), and some fields are not displayed on the left (section "SHAREPOINT FIELDS").
On my custom list, in SharePoint, I have many fields (90 !).

Is there a limit in the number of SharePoint Fields available in Forms ?
Is there a way to access and use the fields currently not displayed in the list ?


Hello @r.jolly,

Welcome to Plumsail Community!

Have you opened the form in the designer and after that created new fields?

If so, please try to re-connect and load the form again.

Also, if you have multiple content types in the form, you need to select the appropriate content type to see other fields.

Thank you for your answer, @mnikitina.

No, I have not. All the SharePoint Fields have been created before.

I only have types "Item" and "Folder". I only use "Item" on this list, and all my fields are available in SharePoint when I create/edit/display an Item.

I've tried to close and opene again the designer : nothing has changed.
I've tried to re-connect and load the form again : nothing has changed.

I don't know if it could have an impact, but the site has been created with the template "Team Site (Classic)", while using the modern experience on the lists.

Problem solved !

The hint about the content type was a good one : the missing fields were correctly associated with the content type "Item", but they were defined as "Hidden" (in order to not be displayed on the standard SharePoint forms, but available in views).
All I had to do was change this "Hidden" settings, and the field appears in Forms.

Thanks !

1 Like

Hello @r.jolly,

Hope you are well.

Where exactly did you change the "Hidden" settings from?

Kind regards,

Hello @MarkMando,

Go to List Settings and make sure that management of content types is enabled.

Then in the List Settings you will see the Content Types section.

Click on the content type name to see the list of all columns. In the column settings you can change the column status.

1 Like

Thank you. Much appreciated.

1 Like