Lookup control field appearance problem

I have a control lookup field and only the first time that I open my form this "problem" appear.


If I close the form, refresh y sharepoint page and click new again, the problem disappear.


The code I'm using is this:

//appearance Supplier lookup control field
var templateSupplier = '';
templateSupplier += '<span class="lookup-col">';
templateSupplier += '<p class="lookup-title"> #: data.LookupValue # - #: data.Code ? data.Code : "" #</p>';
templateSupplier += '</span>';

fd.control('SupplierLKP').widgetOptions = {
template: templateSupplier,
height: 400,
virtual: {
    itemHeight: 35
dataSource: {
    pageSize: 16

What I have to change or do in order to solve this problem?
Thank you.

1 Like

Hello @stefano.mazzi,

Thank you for reporting this! Looks like this is a bug. I will write back as soon as there is a fix.

Thank you for your feedback @mnikitina .
I'll wait the fix then.

Hi @mnikitina & @stefano.mazzi,

I'd like to report that I'm having exactly the same problem when applying a custom template on the lookup control. It looks like the Kendo UI Multiselect control configuration virtual.itemHeight does not initially load the set value from the custom JS written in the Forms Designer. A browser refresh is required for the lookup control's search results to render correctly just like is happening for @stefano.mazzi.

Are there any news on the fix?


1 Like

Hello @tryggvik, @stefano.mazzi,

We've published a fix recently. I've just tested it and the template is now applied as expected. Please clear the browser's cache and test.


Hi @mnikitina!

Appears to be working now - thank you for the swift response :slight_smile:

1 Like

Hello @mnikitina
I just tried and the problem persist


I have already clear the browser cache and re-save the form but the problem didn't disappear.

Do you have any idea about that?
Thank you.


Please check the app package version. Find it in the browser console (F12) >> Sources >> Page >> forms.plumsal.com:

Hello @mnikitina
this is my version
But if I run my plumsail forms client, it doesn't ask to me to update, why?

Thank you.


The desktop designer and the app package are updated separately.

Please download the latest app package from the Plumsail account and follow this instructions .

After updating the app package, please re-save all form types, clear browser's cache and test the form.

1 Like

Hello @mnikitina
I just updated and now I have the last version


Even the "problem" seems to be disappear.
Thank you!

1 Like