PlumSail Form Panel Stopped Working

The form panel is not working as expected. The form started opening in the full window instead of in the pane.

image

image

Hello @cortese98!

Could you please check that the page is 100% loaded before opening the panel form. As there is a slight delay between the time when a user sees the list and when the script loads completely for panel forms.

If that is not the case, please check the URL of the form opened in a full window. The content type should be Item, for example /SitePages/PlumsailForms/{ListName}/Item/NewForm.aspx. In case the content type is different, please refer to How to fix missing forms article for the instructions.

The form has a content type of ‘items’ and opens fine in the full page. The issue is only with the panel.
I did check the language settings and those are correct as well.

The following is the error when trying to load the panel:

image

@cortese98,

Please clean the cache and upgrade the App package in the App Catalog. Please see the instruction here.

Then re-publish the forms that have issues with form panel.

I have cleared cache, upgraded the app package, and re-published the forms and still getting the error/issue with form panels not opening.

@cortese98,

Could you please check the app package version in the console on the form load. Just to make sure it is the latest version 1.0.7

image

Also could you please try to create a new list and to test the panel view in it.

If you have any errors, please send us the console screenshot.

Thank you!

It is still showing as the old 1.0.5.

The app is 1.0.7.1 in my Apps for SharePoint.

I have republished the form. What can I do now?

@cortese98

Please make sure that the old version removed from the App Catalog. Also please check the new version is enabled.

After, please try to create a new list and publish a custom form and check the version of the app.

Please let me know if it’s updated.

Thank you for your help. I deleted the package and uploaded it again and forms are working as expected. Previously I had replaced the file instead of deleting the old one.

Now that the panel is working in modern SharePoint the classic SharePoint pages are not. Also, any items I have linked to via dashboards are all opening in the ‘New’ view only.

Any form that opens in the full browser is redirecting to a new form and will not open in an Edit or Display.

I have tried the following:

  • Reset the Edit form from Custom to default
  • Remove all javascript

Neither of these options fixed the issue

I fixed this issue by also installing the new version of forms designer. Publishing the forms with the new forms designer allowed forms to open as expected.

1 Like

Hi @mnikitina, it looks like this issue is back for us. We're using the 1.0.7.1 SP package and Forms designer 1.5.3, I've tried re-saving, clearing cache, etc. but all forms are opening in full page not the side panel. Any suggestions? I can't remember if deleting the redirect.aspx pages is recommended or not?

Thanks.
Bjorn

Hi @mnikitina,

We are experiencing the same issue as @Bjorn .
On all our forms.
I have latest versions too.

Tried re-saving, checked the panel settings, and the forms_.json file in site pages correctly shows
"panel":{"New":{"size":2},"Edit":{"size":2},"Display":{"size":2}}}.

Resetting the form to default and the panel shows correctly for default SharePoint form.
Save Plumsail Form and it goes back to full page.

Our field staff are using forms with Teams on mobile.
In list view, if the panel doesn't work, then the form doesn't load.

I put a forms webpart on a page and added to a tab in teams, which is working (probably better).

An issue with a Microsoft update?

Adam

Hello @AdamSmith, @Bjorn,

Thank you for reporting the issue! We are looking into the problem already.

I will let you know once we have a solution.

The issue was due to Microsoft's update, but we've just released a fix! Please, clear the cache (or try Incognito mode) and let us know how it goes!

Thanks @Nikita_Kurguzov, that fixed it.

1 Like

Thanks @mnikitina and @Nikita_Kurguzov! Fixed.
Needed a cache clear.

Adam

1 Like

Hey,

I had also the same issue as above and did also upgrade the Forms Version and everything worked again. But now every Panel opens but is completely blank. I am on the current version 1.5.3 and tried resaving the forms and deleting the cache and it did not help. I get those error messages:

If don't open the forms in Panel Mode everything works fine.

Do you have an idea what could solve this?

Hello @JoshMohr,

Please check the app package version in the console on the form load. Just to make sure it is the latest version 1.0.7

image

To install the latest app package version, please follow the instruction in this article:
https://plumsail.com/docs/forms-sp/general/update-package.html?highlight=app

Also, could you please try to create a new list and test the panel view in it.

Hey @mnikitina,

sorry for the late reply. Can confirm that it's the latest version of the app package. A new list also didn't work but when testing I found out that this problem solely happens in Chrome browsers. If I open the same form with Firefox it works fine.