Sharepoint 'get item' action not getting Dynamic data

Hey there,

So I have a flow that uses the Plumsail trigger 'When form is submitted'. It is a public form.
The next action I want to use after that is the 'Get Item' trigger from SharePoint.
However none of the Dynamic data comes up at all, and about a week ago I tried it and it did bring up all the dynamic data from the form.

I have tried starting over and refreshing, I notice that on the 'Apply to each' action all of the dynamic data appears, but I don't know why I would need to use that for this flow so that isn't super helpful.

Does anybody know if this is a known issue yet?

Hello @5by5,

Please share the screenshot of the flow steps so I have the full picture of the case. Thank you!

I have an ID field in my form that would store the SharePoint ID.


Please also expand 'Form is submitted' action and share the screenshot.

Hello @5by5,

Ok, thank you! This is a flow issue, that happens sometimes.
Please try to create a new flow from scratch and recreate steps.

Sadly I tried this several times and nothing worked. Hopefully they fix it soon.

Hello @5by5,

Note that the Id field accepts only integers. So please check that the field on the public form that stores item id is a number field.


1 Like