Tablet users cannot select dropdown items in list control

We have users experiencing an issue on our Plumsail form on their Samsung Android Tablets.

On the form, there is a List or Library control with a lookup dropdown called 'Item'.

The issue is that some items within the list cannot be selected by the users. The workaround is to select the first item in the list, THEN go back and select the item that they couldn't select.

In the attached video, I remoted controlled into a users tablet and attempted to select "Gowns" from the dropdown. I could not. So I then selected the "Bonnets", then went back and tried to select the Bonnets worked. This is the only way to select some items on the list from a tablet.

This is a serious problem and we need an explanation for this behavior. It does not happen on PCs or iPads.

Thank you.


Hello @ParAvion,

What version of the app package are you using? You can find it in the browser console (F12) Sources >> Page >>


Also, is it possible to provide us temporary access to the form to troubleshoot the issue. Please email us to [email protected]


App package:

This issue has been happening for some time now and only affects tablets.

Hello @ParAvion,

You are using an outdated version of the app package. The latest version is 1.0.8.

Please update the app package, re-save the form, and check if the issue on tablets persists. Please find the instructions here: