BUG?: very slow upload and/or error in "List or Library" control when a lookupfield is present

Hi everyone

I have

  • a list "List A" containing some items
  • a library "Library B" containing some folders and documents
  • a modern page
  • a "Plumsail Form"-webpart placed on this page
  • this Plumsail form shows the "edit form" of a specifice item of "List A"

The form itself contains

  • the properties of the list item of "List A"
  • a "List or Library" control that shows the documents of the library "Library B"
    note: there is NO relation between "List A" and "Library B" (no lookupfields etc...)

Case 1
when I open the page and drag&drop 100 small *.txt files on the "List or Library" control, they are uploaded fast and smooth as expected. Upload only takes few seconds.

Case 2
I add a new lookupfield to my library "Library B".

  • this new lookup field does not have to point to "List A")
  • this lookukp field may, but does not have to visible on the Plumsail form

When I try to upload a new set of 100 documents now,
things are considerably slower (5 minuts),
if the upload even succeed!

Is there an explanation for this behavior? How to avoid this?

Kind regards,

Hello @bartplessers,

I couldn't reproduce the issue on my form.

Have you tried to reproduce this behavior on a form page, not on a site page with Plumsail Webpart?

What version of the app package are you using? You can check the version of the webpart and widget in the browser's dev tools > Sources > Page:
Please share the screenshot.

Hi @mnikitina
Sorry for my late response.
I tried this today again and indeed, I can't reproduce this issue.
Both forms-page and webpart-page are responsive and I can't see difference in upload speed with/without a lookupfield.
Maybe a one-time issue or some client problems on my side.
Sorry for this.

kind regards,
Bart Plessers

I'm running:

1 Like