Cannot find the root item

I have OrgChart set up and working for a long time. Since a week ago it stopped functioning and starting showing the error:

“Cannot find the root item ID …”

Nobody touched the configuration, I have checked the data, record with ID exists and it is visible (allowed to read) for every tenant user.

Tried re-configuring orgchart, no help. Tried copying the list to another one, set up new org chart with the new list, and it do not work. What am I missing?

For technical reasons I should stick to original list, not to the copied one.

Tried setting up and configuring the org chart for other newly created list for test purposes and it works ok.

Please help.

Hi @robert.preskar,

Most probably, there is a loop in the Org Chart hierarchy. If you do not specify the Root ID the configuration wizard, Org Chart tries to find it automatically. It takes current user and traverses up by manager unless person without manager is found. This person becomes root employee.

Below is an example of loop:

Person A
Person B
Person C
Person A
Current User

You may either try to find which user creates a loop or specify the Root ID manually:

It should resolve the issue.

Hello @robert.preskar,

Could you resolve the issue?

I would like to add that the described logic works for User Profiles as the data source. If you use a list as the data source, Org Chart looks for the first employee without a manager to set it as the root. If you specified a manager for each employee this would create an issue with detecting the root item.

However, specifying the Root ID manually shold have resolved the problem.

Ok, I have spent some 16+ hour on diagnosing this.


  • Primary employee list is private and not allowed for complete organisation to access, hence orgchart can not be displayed using this list.
  • there is secondary employee (PublicEmployees) list which is automatically updated with subset of data from primary list.
  • PublicEmployees contains two numeric columns - PersonID and ManagerID. Person ID do not corelate with the list primary key column - ID. These two were used to configure relation in the orgchart.

Previously everything worked ok for months and suddenly orgchart started showing this error. Nothing has been reconfigured, neither public list nor private (except of data of course).

I have generated dumps of data and rechecked eventual looped manager relations, but they do not exist - checked as you suggested.

Started playing and generating different orgcharts with test data. One thing popped up. Whenever I use different unique column which is not ID of the list it doesn’t work. So this started happening at some point of time, can not conclude did MS changed some internals or this triggered another bug.

Please advise what to do next?

BR, Robert.

Any update on this issue?