Error: The content type does not exist

i am getting this error for some user what might be the issue?

Hello @ShantiBhattarai

Could you please provide more details about the issue.

When do you get the error?
Which users get the error? Do they have access to change the content type?

so what happened is if i add user to member group they were getting old classic look and getting that error and once i gave owner permission they were able to see the form but we dont want all having owner permission on site


Does the Members group have an Edit permission level? Have you modified Edit permission settings?

Please also make sure that the SharePoint Lists and Libraries experience feature is disabled in Site Settings >> Site Features.

member currently have default edit permission i have not made any changes but i want to remove delete item permission later once this issue is resolved i checked site feature and SharePoint Lists and Libraries experience feature is disabled in Site Settings.


Have you designed the form for all content types?
Could you please share screenshot of the form opened in the browser and in the designer.

Do you see this behavior only in one list?

Have you changed access permissions for the SitePages library?



I am facing same error for below scenario:

I have created document library and customized plumsail form in it. Then saved this document library as template.
Using this template I created new document library in another sub site. Library was created successfully but when ever I try to edit properties of any item inside this library then it says "Error: The content type does not exist." Same error also comes when i try to upload any new file in library.

Looking forward to your reply.

Hello @shahid.furniturewala,

Welcome to Plumsail Community!

To re-use the form in other lists/libraries, you need to either export/import the form or provision Form from one site to another programmatically, using Visual Studio and our NuGet package.