Failed update 2.8 to 2.10 Workflow has been deprecated


#1

Hi,

I followed the procedure, deactivated the feature in each site, deactive the solutions and loaded the new wsp. I cleaned the sharepoint designer cache and updated it.

The new workflows work. But previously created workflows (2.8version) do not work. The error is “The associated workflow has been deprecated”. And in “sharepoin designer” it shows the following error “Failed to load this workflow To correct this problem, restart Sharepoint Designer”.

Can you help me with this case?


#2

Hi. I installed sharepoint designer on another computer and the same error occurred, that I can not edit some workflows from version 2.8. For some reason, the “deprecated” error no longer occurs and the workflows are running according to the actions of the sharepoint online lists.
There are some workflows that have WActionPack actions that I can not edit. If I go back to the installation of version 2.8, I can edit worflows, if I installed version 2.10 I can not edit it.
Should I re-create workflows that can not be edited in sharepoint designer?


#3

Hi @Msaenz,
Thank you for your message.

After installation of 2.10 version you need to open Plumsail Actions Pack page ("Site Settings -> “Plumsail Actions Pack”), specify credentials for running workflows and then press on “Upgrade” button for starting the process that upgrades your existing workflows. After upgrading you need to open workflows and re-publish it.


#4

Thank you very much Evgeniy, the procedure solved the problem for me. In a specific site, the option ("Site Settings -> “Plumsail Actions Pack”) did not show the corresponding screen to configure the workflow. When inspecting the element has the following description:
Plumsail Actions Pack