Form loads and disappears, log shows some error

Forms on our sharepoint online were working all good but suddenly it start throughing error. First form loads completly and then disappears when i open console for debug i can see some error, please refer to attached image.
Here one thing is important that I created brand new list and deployed a very simple form that did not work as well.

Hello @Sairfan,

Our SharePoint forms have been negatively impacted by the latest Microsoft update. This update clashed with our forms, and caused them to fail rendering. We are sorry for the interruption of the work process this could've caused to you and your company.

However, our developers have addressed the issue as soon as possible, and we've released a hotfix, please:

  1. Make sure you have the latest version of the app package installed in your app catalog - Installation of Plumsail Forms for SP Online (Microsoft 365) — SharePoint forms
  2. Download and install the latest version of the desktop forms editor from the Plumsail account - Plumsail Account
  3. Clear browser's cache and re-save older forms with the new editor

This should solve the issue! We're looking for your feedback, let us know how the update works!

Hi after update application and saving new form I'm still having error (though not always) and also I get similar error while if I scroll on opened list item.


Please confirm that these updates will solve this issue?



Have you re-saved all forms and cleared browser's cache?

Hello @cknightTSY,

Yes, updating the app package and re-saving all forms using the latest version of the designer will resolve the issue.

@mnikitina I tried it on Chrome Incognito Tab, Edge browser, cleared cache many time, it works one/two times but then again get into same error.


Please check the version of the webpart and widget the form is using. You can find it in the developer tools (F12) >> source >> page >>


Share the screenshot.

In there i can see widget/1.0.8 does not match with verion in picture share by you.


On the other side I can see correct version installed in Sharepoint Admin,

And yes, I cleared the cache multiple times.


You need to resave all your forms for the source list to update the widget version. Have you done this?

Yes, I downloaded new Plumsail form app, imported previously built forms to it, and from there I published (Saved) those forms through new application.


Have you re-saved all forms (Edit, Display, New) for all content types and forms sets?