Forms within MS Teams?

I'm testing Forms on a SharePoint list, so far so good when using it in a browser. But when I add a tab in Microsoft Teams to show the list, it only works when you choose the tab type 'Website'. When I add the tab as 'SharePoint' list, calling the form throws the following error "Something went wrong. Try again later..."

I'm guessing this is some cross-site scripting limitation within the embedded browser in Teams? I can use 'Website' tabs, even though that has some limitations (mainly the gray error bar they add to all websites). Just wanted to see if you guys have seen this behavior before, and if there's any workaround. Thanks.



Hi!

We are researching this issue. Please use a ‘website’ tab until we find a solution.

Hi!
We've fixed the issue. Now, a form panel should open in a Teams tab properly. Please, clean the browser cache.

Awesome, that did the trick. Thanks much!

Displaying sub-sites in teams is not supported using the "SharePoint" tab. We have to use the "WEB" tab. This functions correctly until I update the form and save it. Not only does the panel no longer function but the redirect to the new form loads blank?

What am I missing?

Thanks!

Works fine for me with Website tab:

Could you check the forms in SharePoint - do they open properly? Ensure that the forms are completely saved before opening them in the browser - the designer shows a corresponding message once the forms are published. Also, if you have multiple form sets for this list, ensure that the routing works properly.

The datatable [add item] button it's not doing anything when I clicked, this is embebed in a Teams tab, do you have any suggestions?

Hello @Carlos_Torres,

I could reproduce that with my form.

What version of the designer and app package are you using? Please share the screenshot.

You can find the designer version at the top left of the application:
image

And see the app package and widget versions in the developer tools (F12) >> Source >> Page:
image

Hello @mnikitina,
Seems I have the webpart version 1.0.7.1
image
and designer version 1.4.8
image
if this help to find the root cause of the issue, I tried also Teams from web (not the app) like this image shows


and having the console from dev tools showed me lots of errors as shown in those images below

other screen shot

Hello @Carlos_Torres,

Thank you for screenshots!

Since version 1.0.7, many updates and bug fixes related to MS Teams have been published.

You should update the app package and re-save the form you want to use in MS Teams using the latest version of the desktop designer - v. 2.0.6.

@mnikitina that's great it worked thanks a lot, but I have some issues or errors

  1. this prevent from debugging the form, can you please help me to fix it?

  2. in the fiels validation somtime I read json or html characters, can you please help me to prevent this to happen?


    Also other existing forms failed after updated the package
    image
    And when I tried to save them from the new designer, it showed me the error below
    image
    Even if I followed what they suggested
    image
    Any suggestions?
    Thanks in advance
    Carlos

Dear @Carlos_Torres,
Let us try to help as much as we can:

  1. This is not something we can fix, these are Microsoft errors, pretty common as far as I can tell.
  2. This is interesting, it seems like Internal Name of the field is very strange, can you check the Name of the required field in the desktop editor? Select the field in question and check here:
    image
  3. As for the scripting capabilities, it's possible to have it enabled in the UI, but still disabled on some sites, unfortunately, we recommend using the Power Shell method described here to make sure - Plumsail Forms scripting capabilities — SharePoint forms

hi @Nikita_Kurguzov ,
2. I didn't understand, anyways I verified that the internal name is not a key word used in the column definitions, this comes from a radio button validation.
image

3.worked perfectly
4.This is new


the form width seems to be 50% after saving it with the new editor, is there a way to set it to 100%?
Thanks a lot
Carlos

Dear @Carlos_Torres,
Actually, you're right, it's not the Internal Name, but the Title which is used, can you screenshot it for me?
image

As for the panel, it can be changed to full screen in Form Mode settings:

Hello @Nikita_Kurguzov

  1. I discovered, we have a function to translate control titles, it comes from a resource json file, in the old version it behaved well.
    2.It worked well thanks.
    3.Do you know an automated way to update the entire company plumsail forms in a batch way? avoiding to open them (one by one) from the new designer and save them? that will be tedius.
    Thanks a lot
    Carlos

Dear @Carlos_Torres,
We do have Provisioning API with NuGet package for Visual Studio to automate provisioning of forms - Plumsail Forms Provisioning API for SharePoint — SharePoint forms