Hidden rows not being hidden

I have a form where I have a number of grids which are shown/hidden based on the previous selections. When I loaded the form today I found it had a huge amount of white space which, when I investigated further, I found was caused by another row setup to contain my hidden grid:

Is there a way I can make it so this parent row is also hidden if the first child is set to display: none;?

Dear @astokes,
How are you hiding grids? Can you share the code?

Hi Nikita,

In Plumsail Forms I have been setting the cell properties to display: none; under style:


I can confirm that there is no other container above that one in Plumsail Forms.

Just a gentle nudge on this one as we are getting some grumblings from some of our stakeholders.

Resolved this - I added some code to hide the parent rows when a grid is hidden :slight_smile:

1 Like

Dear @astokes,
Good! However, we were not able to reproduce the issue with your previous code either. Might be the case that you need to update the app package or the editor to get the latest functionality.