Installation Workflow Action Pack SharePoint SE


Im running into some issues while installing the Action Pack on our SharePoint SE Servers..

It says that it's already installed but i cannot find the features on the web application to activate.



Hello! Using the wizard, please try to remove Actions Pack and install it again.If it does not help, you can try to enable the solution with a command or deploy it manually:

i already tried that a couple of times with commands, wizard, redeploying and so on.


Dario, developers advised to follow the instruction below.

Delete Actions Pack following these steps:

  1. Deactivate the feature on the site:
Disable-SPFeature -Force -identity "22bb2cee-2403-4b7c-818e-9078b11a218b" -URL "http://yoursiteurl/"
  1. Deactivate an Auth feature on the web application:
Disable-SPFeature -Identity "1b03dac6-1f50-4553-90bb-800aa5d37b21" -Url "http://yoursiteurl/"
  1. Uninstall & remove the solution:
Uninstall-SPSolution -Identity plumsail.actionspack.onpremises.wsp -Verbose Remove-SPSolution -Identity plumsail.actionspack.onpremises.wsp -Verbose
  1. Perform the IISReset command.

The WAP package shouldn't be in Central Administration > System Settings > Manage farm solutions. If necessary, retract and delete it from there.Then, install the solution using a WSP package and following this instruction. You may also need to enable the feature manually as it is described here.

Still doesn't work.
I always get the same error, doesn't matter which way i try to install the solution.

Cannot add the specified assembly to the global assembly cache: Plumsail.WFServices.Models.dll.

Does it maybe affect the Installation that we have 2 servers and one acts as: Application and Search Server and the second as Front End and Distributed Cache Server but both have the Microsoft SharePoint Foundation Web Application Service running?

I would appreciate it, if you can help me.
i tried every possible solution found on the internet regarding the problem i have right now.

I don't know if maybe the DLL that should be copied is not available or that because i have already the Plumsail.forms.sp2019.wsp package installed the DLL is already there and cannot be copied because of that.

kind regards,

Hello @Dario_Chiga,

Would you mind to drop us a email at [email protected] in that case we would be able to schedule a screensharing session to resolve the issue?


1 Like

Alright works perfectly now.

Solution was to use GACUTIL.exe to add the DLL to the assembly.
Then via powershell execute the scripts you added in this post but with enable instead of disable and then it worked.