Plumsail Form Application Sign in different user


I was just issued a new laptop and upon accessing Plumsail form application, its logging in using my corporate login credentials.

I want to sign in as a different user but there is no option to do so. I even signed out myself from all the browsers but its still uses my corporate login automatically.

Is there a way to make Plumsail to login using different O365 account?

Do advice.



Dear @W.T,
Thank you for contacting us! The authentication process is a little different for different version of the app, so, could you, please, send us some screenshots of your login/form select screen, so I can check and offer you the correct path?

Hi Nikita,

The authentication issue I encountered is not from within the form but rather on the Form Designer. I'm unable to get the version but it should be the latest one as i saw it being updated before being launched.

I've attached the screenshot. Do assist!

Dear @W.T,
What if you try to sign in with another account? Normally, it should work, just like in any other browser. Attaching a GIF as an example.

1 Like

Dear Nikita,

The selection screen for accounts didn't appear. It went straight and automatically logged me in using my default account.

When i click on the "Click here to sign in with a different account to this site", it threw an error.

I've also disabled the Windows 10 Credentials service but with same result. Is there a cache credential which Plumsail uses? I did remember it worked at least once before this.

I'll try to do a reinstall and see if it helps.


Hi Nikita,

I run the application using a domain user without administrative rights.

After i uninstalled the application, I installed and ran it under another account with local admin rights and I could see the window to request for O365 Sign In.

It is possible that:

  1. Using Local admin account doesn't do SSO as such the prompt appears.
  2. Possible that administrative rights is required to run this application; perhaps some processes which calls for the Sign In page is prevented access.

Nevertheless, as our laptops are locked down, I won't be able to test the item 2.

I'll continue to launch the application using the local admin credentials.



Dear @W.T,
The cache we're using is IE. Please, try clearing the IE cache fully, and see if you can login using IE. If it works, it should also work with Forms.