Problem with MS Form document generating a PDF and data not transferring

Hi, I am new to Plumsail and need some assistance please.

I am generating a PDF from an MS Form response and the Power Automate flow works fine and generates the PDF document, however the data from the form is not appearing. As far as I can see I have the correct format for the tokens on my Plumsail Document template, but they do not appear to be generating.

I have copied the template tokens and flow response from the 'Start Document Generation Process' in Power/A.

I hope the images render ok, if not the token format from the template is below. I have checked the MS Form question text and it matches etc:

Name of company (as per Companies House) {{Nameofcompany(asperCompaniesHouse)}}

Review period FROM: {{ReviewperiodFROM:}}

Review Period TO: {{ReviewperiodTO:}}

Please provide the total gross revenue during the review period? {{Pleaseprovidethetotalgrossrevenueduringthereviewperiod?}}

Any assistance would be gratefully received.

Kind regards,


Hello @steve.taylor,

  1. The tags in the template don't have spaces but there are spaces in the JSON. Use the same names in tags and in the JSON.

{{test}} - tag in template


"test" : "hello, world!"

  1. I'd not recommend using these symbols in the tag names:

":', "(", etc

The best way is to use simple names without spaces in the tags and the same names in the JSON.

  1. Please review our examples for Power Automate

and for Processes

Best regards,
Plumsail team

Hi Petr,

Thanks for your help below. Unfortunately, it still hasn’t dropped the response data in with making the corrections you recommended. I had also tried making the first field (name of company) a fixed answer rather than pulling from the MS Form to test, but it doesn’t translate over to the Plumsail template.

Name of company {{nameOfCompany}}

Review period FROM {{reviewPeriodFrom}}

Review Period TO {{reviewPeriodTo}}

Please provide the latest company valuation and date applicable from?

I am also getting this error and the system times out without saving any changes that I had made to the template. In addition, when I click on the highlighted ‘Tokens’ field to check them and to update, it again just times out. Any ideas what I am doing wrong?

Thanks again for your help.

Best regards,


Hi Steve,

The error message should be fixed now. Please retry the process and if it's still not filling the template, share with me the template and I'll try to reproduce the issue.

Best regards,
Plumsail team