Remove permission from item error

I use below command:

remove <<>> permission from item <<>> in list <<> for user or Group <<>>

but it always fails, returning in history log this error: “Exception: Can not find the principal with id: 17.”

I tried to launch workflow manually and automatically, but nothig chenged

Please, help me!


Hello Andrea,

Could you please try to navigate by the following URL:
your siteUrl /_layouts/15/userdisp.aspx?ID=17

I suppose you are trying to grant permission to some group, but the group contains invalid accounts.

When I try to navigate to that address, arrive to DELVE user profile. I suppose this is not the problem, because I tried to change the user, and error message is exactly the same. I tried to setup a Group, and reteruned same messagge.

I tried REMOVE ALL PERMISSION FROM ITEM, and it works fine, but when a use GRANT EDIT PERMISSION on USER X, it doesn’ t works. It seems that GRANT/REMOVE PERMISSIONE ON USER X doesn’t works.

I use following syntax, found in an article of your blog:

REMOVE edit PERMISSION FROM ITEM current element:id IN LIST working context: current list FOR USER OR GROUP

Is this correct?

Please let me know, thk’s

Is there any news? Thank’s