Sending Email with Attachments

Hi, I have SharePoint Online.
Using the Send Email with Attachments workflow action is not attaching my word doc attachment from the list item. Everything else seems to work including the inline image attachments however.
Oh, why does the email I get back have your no-reply address in it???
“CSR-WalmartRF [email protected]


David Infante
[email protected]

Hello David,

We were able to reproduce the issue with attachments, it is a bug, we will fix it during a two days. I will let you know about the update. Alternatively, you can use old method which was described in the following blog post:

Oh, why does the email I get back have your no-reply address in it???
We use own SMTP server to send an email if you want you can define your own in advanced settings in the workflow action.

Have you updated the Workflow Pack for Office 365 yet so I can download and test it again?
We are anxious to buy your product! :smiley:


David Infante


Sorry for the delay.
Yes, we updated the product, please download the latest version:
Upgrade instruction

I'm getting an error in the workflow now? I've tried to delete the action and re-add it but it still is not working. I then deleted the whole workflow and started from scratch and got the same results.

I followed your update instructions exactly but it should be noted that I didn't see an upgrade notification once I went into the Plumsail Actions Pack under Site Administration.

"If any of workflows are required to upgrade, you should see the upgrade notification, otherwise all alright."


Please write us at [email protected] we can setup screen sharing session to diagnose and solve it.

We updated the product.
The option “Add Item Attachments” works now.

Hello we just downloaded the trial version and testing the sending email with attachment action and it is not working. Is there another link to download the version with the update your are speaking of?

Hello @erockafella,

Could you please open your Site workflows, find there the workflow and click on the “i” icon?

Also, please send me a screenshot of your workflow with properties window opened via PM.