'Unauthorized' error when signing in Pl. Action pack

I am now evaluating workflow capabilities of the tool. For now I am stuck when adding admin credentials in Plumsail Actions Pack in Site Settings. Even though I am global admin, I cannot be authorized on the form that appears on clicking on ‘Plumsail Actions Pack’ link. Error says: ‘Can’t connect to site: Cannot contact web site ‘https://XXX.sharepoint.com/’ or the web site does not support SharePoint Online credentials. The response status code is ‘Unauthorized’’.

My guess is that it is related to the LegacyAuthProtocolsEnabled=false. Can it be the case?

Note, that I can connect to the tenant administration site via Powershell.

Another thing that concerns me in the error, is that it does not connect to XXX-admin.sharepoint.com site.

Edit: Authorize in Powershell works fine if credentials are not passed from script: “connect-sposervice -url XXX-admin.sharepoint.com
but it fails with the same error if I pass credentials:
$usercredential = get-credential -username $adminupn
connect-sposervice -url XXX-admin.sharepoint.com -credential $usercredential

Nevermind. Problem was solved by enabling LegacyAuthProtocolsEnabled.

Hi Artem,
Good to know you managed to fix it.

Best regards,
Andre Lima.