Upgrade issue

Upgrading from 2.9.5 in order to get the user properties actions. Following the upgrade instructions the installer found all prerequisites and completed successfully. However immediately after:

  • portal became unavailable with 503 errors
  • IIS was shutting down the app pool due to multiple WAS process errors

Reverted the install due to availability requirements. Did notice that the Plumsail Authorization feature on the web app had gone deactivated. Would activating that be a possible cause ?

Any assistance would be greatly appreciated. We rely heavily on the SPForms tool and have high expectations for actions pack as well.

thx much

Hi khardy,
Thank you for a message.

Please, open “Central Administration”, then choose “Manage web applications” in “Application Management” section. Select the application where you installed Action Pack and in ribbon panel click on “Manage features”.
In this list, you may find the “Plumsail Authorization” feature.

Best regards
Evgeniy Kovalev
Plumsail Team

Thanks Evgeniy

Yes, aware of the option in web app features. The question is: should we expect to see 503 errors if this feature is not enabled after an upgrade ? Trying to understand the behavior better to reduce risk in our production environment.

tx

Usually, this problem occurs when you trying to upgrade or remove the application without deactivation the “Plumsail Workflow Actions Pack” site feature.

After future upgrades, please, make sure that the web application level feature “Plumsail Auth Service” is activated after the upgrade. If you will have same problems, please write us by email to [email protected]

Best regards
Evgeniy Kovalev
Plumsail Team

Thanks. We did deactivate the Plumsail feature in sites where it was activated but certainly could have missed one. Two suggestions:

  • note this in the upgrade instructions - really don’t expect to see a 503 just from upgrading a component pack. If failure to deactivate every workflow instance could lead to a 503 that needs to be identified.

  • ideally, fix it - it’s really an odd and serious behavior.

  • add a note for reactivating the authentication feature as well - didn’t see that in the upgrade instructions.

As always, do appreciate the great tools and support.

We’ll redo the upgrade tonight and ping you on support with any further issues.