Workflow says my doc has been deleted

when I add a metadata to my doc, the workflow removes all permissions and add some others.
It works fine when I do it (i am site coll admin) but when it's a user with contribute permissions, it fails. The workflow runs with the name of the current user and that is why, I guess, once all the permissions are removed, it does not see the doc anymore.
I need the workflow to run with as a site coll admin otherwise it won't be able to do what I want him to do.
Is there a way to do that ? the workflow Below, different screenshots

Thank you for your help

Hello @Virginie

Please right click on the action and chose properties. In the properties please switch “Run as account of publisher” option.

Hello Roman,

Here is what I get in the action properties :


Do I have to fill in those Admin fields ?
Thank you for your answer.


Sorry, I’m a bit confused about which version of the product do you use.

Do you use the Online version? If so you can specify an account which will be used to run the workflow via settings page: Site Settings -> Plumsail Actions Pack or you can specify the users directly via AdminLogin&AdminPassword fields.

Hello Roman
I am using the online version and I defined myself in the settings (I am site coll admin).

But when the workflow runs, it runs with the name of the current user :

So, how can I change this, because the current user does not have enough permission to see the document the workflow is supposed to modify ?
Thank you very much for your help,

The workflow runs under the current user, but our workflow actions run under the specified user.

To check, you can try to create a new list item using our actions and check author info.