API Key not working


#1

Hi,

My connection to Plumsail don’t work, it says “Invalid Api key” but it worked this morning!!
Everything is setup correctly so please help!

Screenshot%20at%20Nov%2007%2015-10-57


#2

Hello @ErikLm,

Could you please let me know TraceId of the request?


#3

Here,

0HLI4MNGN60FD:0000009F


#4

Did you find any problems?

This is in production so thats why i’m a bit stressed.


#5

@ErikLm,

Please press “…” on the action and choose “Add new connection”, specify your API key from account.plumsail.com

image


#6

I have already tried that, didn’t work either. It’s been working perfectly until now, is it a problem on your side?


#7

This is also effecting me as of the last hour or so. I don’t think you are alone.

My TraceID: “0HLI4MNGN60FM:00000015”


#8

Well, whatever it was is now working - if this was a plumsail issue, would be good to know what it was :slight_smile:


#9

@DanF

We are researching the incident. I will provide more details ASAP.


#10

I also experienced the same issue for about a half hour this morning. The flows that ran after that time worked without the error. I did not change anything and the flow was automated and set to pause for 20 minutes if an error occurred and then continue. This is a production script so I would like to know why it failed to run this morning and then suddenly started working again.

The error that I received twice during the half hour period was:

“error”: {
“code”: “Exception”,
“message”: “Invalid API key (API key removed…) Please follow this instruction to get correct key: https://plumsail.com/docs/actions/v1.x/getting-started/sign-up.html”,
“date”: “2018-11-07T14:51:22.5243459Z”
}


#11

We investigated the issue, it occurred accidentally because of human mistake.

We will make some correction our development and deployment process to prevent similar issues in the future.

I have to say it one more time, we are very sorry for the issue and will do the best efforts to avoid this.

Additionally, as an apology, we will extend the licenses of affected users for an additional two weeks.


#12

Thanks Roman. I’m grateful of the openness :slight_smile: