Blank forms after opening since some days


since the weekend we can't use Plumsail Forms anymore. After opening a form (Sharepoint Online), i can only see a white window. I updated the desktop app. I deleted the form and the standard sharepoint form opens correctly. After adding a simple field, the behavior repeats. I've not added custom javascript and other settings.

I get some errors

What can I try now?

Edit: I created a ticket now.


Hello @Hagrid,

Does this happen with all forms within the domain? Or you can't open a specific form?

Have you made any changes to the tenant, site, or list settings?

Could you please share the screenshot of all errors from the console when opening the form. You can filter all console messages, to show only errors.

Hi @mnikitina

Thanks for your reply.
I tried it with 2 used (similar) lists in different site collections and got the same error.
I created a new list with the same content type and can open the form (at the same sitecollection). Then I imported the old form settings and i can still open the form. So it seems to be a list problem?
Any ideas about possible problems? I didn't changed anything (except for a microsoft flow setting last friday. After this it was still possible to open the form).

Here is the error log:


You are right, most probably this is related to the list.

What is the type of these lists? Were they created from the template?

Could you please share the screenshot of the blank form, including the page URL.


it is a "task list", but with a custom content type on top.
Because of your question I tried some different things and have new insights:

I created

  • a custom list with my custom content type -> form works
  • a task list without my custom content type -> form works
  • a task list with my custom content type and the form displayed NOT as dialog box -> form works!
  • a task list with my custom content type and the form displayed as dialog box -> form does NOT work

So it seems to be a combination of the last settings. But the last few weeks everything worked fine :slightly_frowning_face:

Something I noticed while testing:
Last week I created another thread with an untypical behavoir of the displayed form title "DisplayForm".
This problem does not occur in the custom list without a template. Also the form gets displayed as dialog box on the right side of the window:


Thank you for these details!

Why are you using the Classic experience of the list? Is there any particular reason for this?

Plumsail Forms is designed for Modern experience, and we suggest using the New experience to work with forms. Thus, forms opens in a full screen or in a panel.

You can switch list to New experience in the List Settings >> Advanced settings >> List experience.


after switching, it works now. The problem is, that we're using a custom layout to display a kanban board. This seems not to work in combination with the "new experience". I will check the settings.


We'll check if this is a bug or Microsoft updates changed the form behavior. For now, you can switch to a new experience.

I'll let you know once I get a reply from our developers.


We've published the fix. Please completely clear the browser cache to get rid of the issue.