Can't Use Email (Exchange)

When I try and use one of the workflow actions to send an email(enterprise, originally with attachments, however I have tried without) it fails with the following exception:

Could not load file or assembly ‘Microsoft.Exchange.WebServices, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35’ or one of its dependencies. The system cannot find the file specified.

The normal email action (email these users) still works however.

System: SP2013 Standard On Premise
Workflow Action Pack (Trial Version)

Hello Roland,

Could you please ensure that you use the latest version of Workflow Actions Pack.

Usually this library is installed with the product, but also you can setup it manually. To do this please download and install Microsoft Exchange Web Services Managed API 2.0

Pretty sure that I have the most up to date version of the Action Pack as I downloaded it from this site the other day.

As for EWS I have tried both v2.0 (from your link) and v2.2.

I also have the same problem with the smtp method.


Please write us to [email protected], we can schedule screen sharing session to resolve the issue.

Did you resolve this situation?
I have the exact same error message on all exchange email related actions - in a SP 2013 OnPrem environment.

Have tried to manually install the Microsoft Exchange Web Services Managed API 2.0, but it did not make a difference.



Yes, the issue was resolved after installation Microsoft Exchange Web Services Managed API 2.2 … x?id=42951

If it doesn’t help please write me at [email protected], we can setup screen sharing session to solve the issue.

After installing this, I get a new error message:

Exception: The Autodiscover service couldn’t be located.



Usually this error means that the service can’t find Exchange server. Could you please ask your system administrator to ensure that it works correctly.

Alternatively you can use IMAP and SMTP versions of workflow actions.

Stupid Question, but where do I need to install this? on any of the SP servers? exchange server? sql server? i'm lost...