Datatable Date changes to a random future date

I have a data table that I plan to use for setting a list of expense items and when these were purchased so would like to have a date, description, account code etc set up in a datatable that will then be manipulated in a flow later.
I have the required columns set up and have set mandatory fields as appropriate and wanted to test how this would look in the SP list I want to store data in.
When I attempt to select a date around today the date displayed teleports to a month and nine years(!) into the future. It's never seemingly quite the same date but here's a couple of screen snips of the intended date and then the displayed date (bare in mind this is dd/mm/yyyy format)
image
image

It also takes an age to do this if selecting from the picker especially compared with typing a date.

upon every change I receive this error in the console

Uncaught RangeError: Maximum call stack size exceeded
at Ve (forms.plumsail.com/widget/1.0.7/spform.js:42)
at s.e.$emit (forms.plumsail.com/widget/1.0.7/spform.js:42)
at init. (forms.plumsail.com/widget/1.0.7/assets/js/25.cfcb7aeb5577525bd9b0.js:1)
at init.trigger (forms.plumsail.com/widget/1.0.7/spform.js:96)
at init._process (forms.plumsail.com/widget/1.0.7/assets/js/0.3468d6ee456d48b80356.js:1)
at init._change (forms.plumsail.com/widget/1.0.7/assets/js/0.3468d6ee456d48b80356.js:1)
at init.o (forms.plumsail.com/widget/1.0.7/spform.js:82)
at init.trigger (forms.plumsail.com/widget/1.0.7/spform.js:96)
at s. (forms.plumsail.com/widget/1.0.7/assets/js/0.3468d6ee456d48b80356.js:1)
at s.trigger (forms.plumsail.com/widget/1.0.7/spform.js:96)

Appreciate any insight into this.

Hello @Andrew.B,

Welcome to Plumsail Community!

You are using the outdated version of the app package, the latest version of the app package is 1.0.8. Please update the app package following these instructions .

After the update, you might need to re-save the form using the latest version of the designer (1.7.2).

If the problem persists after updating the app package and resaving the form, please let me know.

Hi, Thank you for your response and the above has now been completed.

I have in the intervening time after the update:

  • Reset the form
  • Deleted and created a new list
  • Recreated the form

After an hour of being on the new package and resaving the forms to hopefully bring them up to scratch this has not solved this date jumping issue.

Hello @Andrew.B,

Please completely clear browser cache and check if that resolved the case.

If not, do you have any custom code on the form? Please comment it out.

What steps do you have in the flow?

Could you please share the screenshot of the form and the flow steps.

Hi @mnikitina
You might remember I said I deleted the SharePoint list and recreated it.
There is no flow to have steps in. the item and datatable is saved directly into this list by the designer with the datatable inhabiting a multiline text field in the same.


As shown in this screenshot this is a bare form with the datatable having 5 columns
1 date, 2 single line text and 2 number fields


This screen shot shows that there is no JS to speak of and that the sample text is still there for the time being.

I have tested this on a couple of different computers and browsers so even though i have ckeared my cache this hasn't helped.

Thank you for your patience.

Hello @Andrew.B,

Thank you for the details! Unfortunately, I couldn't reproduce the issue on my side.

Is it possible to provide us temporary access to your SharePoint Site to troubleshoot the issue? Please email us at [email protected]

I'm having the exact same issue. Am running version 1.7.7 of the designer.

Hello @wojoNZ,

I'm sorry, I've missed your post.

There are several issues mentioned in this thread. What is your problem? Could you please provide more details.

Hi, i have the same issue for the date picker inside the data table. I am on version 1.8.5. Is there a solution for this? Thanks!

Hello @zymwh,

Do you have any custom code on the form? Please comment it out and check if the issue persists.

If that won't help, please check the browser console for the errors when the date is changing.

We also suggest you update the designer to the latest version which is 1.8.8.

Hi thanks for the reply!

I have created a test list and simply add a data table to it. Simple list, simple form, and no custom code, but I still get the same issue. I am on 1.8.5.

As a few customers have the same issue, why you cannot reproduce it is strange. I am with SharePoint Online, same issue with Chrome and Edge.

Error message:
Uncaught RangeError: Maximum call stack size exceeded
at Ve (spform.js:51)
at a.e.$emit (spform.js:51)
at init. (26.25d0225286060e2d2dc5.js:1)
at init.trigger (spform.js:119)
at init._process (0.30484b6326fccf21ae9e.js:1)
at init._change (0.30484b6326fccf21ae9e.js:1)
at init.i (spform.js:114)
at init.trigger (spform.js:119)
at a. (0.30484b6326fccf21ae9e.js:1)
at a.trigger (spform.js:119)

@zymwh,

Please update the the desktop designer, re-save the form and try reproducing the issue.

If the issue persists, please record the short video demonstrating the behavior.

The problem might be due to Microsoft updates that are not published to all tenants at once.

Hi, I'm having the same issue as described by zymwh (Oct 21)
App version 1.1.0.0, Designer version 2.0.1. The site locale is English (New Zealand) (dd/mm/yyyy).
I have setup a new list and form. Is there a fix for this?
Thanks

Hello @netifysolutions,

Welcome to Plumsail Community!

Do you have any custom code on the form? Please comment it out and test the from in incognito window.

If the issue persists, please record a short video demonstrating the Date column behavior.

Hey,

I'm also having the same issue as Andrew B where selecting a date in a data table doesn't work correctly and the date jumps forward a number of years causing the same error in the console.
PlumsailError

Also, selecting a date from the Date field (not in a data table) always jumps the date forward by 1 day.
The Date and Time field works correctly though.

In this screenshot I have selected November 10 2022 in every field and this is the result as explained above.

I am creating the form in a web browser (tried Google Chrome & Edge).
Clearing the browser cache didn't fix the issue. Uncommenting custom code didn't work. Running the form in incognito didn't work.

Hello @reubenb,

Welcome to Plumsail Community!

What SharePoint version are you using? Online or On-Premises?
What is the version of the desktop designer?

If you are using SharePoint Online, please check the version of the app package. You can find the app package version in the browser console (F12) >> Sources >> Page >> forms.plumsal.com
image

Hi @mnikitina

I'm using SharePoint Online and I'm only using the web editor not the desktop designer.

PlumsailAppVersion

@reubenb,

Do you embed a public form in a SharePoint page using the Plumsail web part? Please share the link to the public form. You can send it in the DM.

@reubenb,

Thank you for the link, but there is no Data Table control with the Date column.

And I couldn't reproduce the issue on my form. Could you please test it on your side:
https://m-nikitina.plumsail.io/26fba0a1-be78-4d98-a378-388eac6de09c

@mnikitina ,
Sorry about that I replaced them with strings for the time being. I'll make another form with date fields and send it to you once its approved.

I was able to reproduce the error using the link you gave, where the exact same thing happened as in my first post. I submitted the response too if that's useful.