Error trying to access Plumsail account settings


#1

Hi,

I am having a problem accessing the Plumsail Actions Pack account setting in our SharePoint Online tenancy. When I log in, I get the following error message:

Can’t connect to site: Cannot contact web site ‘https://xxxx.sharepoint.com/’ or the web site does not support SharePoint Online credentials. The response status code is ‘Unauthorized’. The response headers are ‘X-SharePointHealthScore=0, X-MSDAVEXT_Error=917656; Access+denied.+Before+opening+files+in+this+location%2c+you+must+first+browse+to+the+web+site+and+select+the+option+to+login+automatically., SPRequestGuid=7b011d9e-3068-4000-9128-3f4000102c0f, request-id=7b011d9e-3068-4000-9128-3f4000102c0f, Strict-Transport-Security=max-age=31536000, X-FRAME-OPTIONS=SAMEORIGIN, SPRequestDuration=1143, SPIisLatency=1, MicrosoftSharePointTeamServices=16.0.0.6913, X-Content-Type-Options=nosniff, X-MS-InvokeApp=1; RequireReadOnly, Content-Length=0, Content-Type=text/plain; charset=utf-8, Date=Tue, 26 Sep 2017 11:20:40 GMT, P3P=CP=“ALL IND DSP COR ADM CONo CUR CUSo IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM INT NAV ONL PHY PRE PUR UNI”, Server=Microsoft-IIS/8.5, X-Powered-By=ASP.NET’.

Can you help?


#2

Hello,

Could you please check if legacy authentification is enabled. Please use SharePoint Online Management Shell

Connect-SPOService -Url "https://TENANTID-admin.sharepoint.com"
$TenantSettings = Get-SPOTenant
$TenantSettings.LegacyAuthProtocolsEnabled
Set-SPOTenant -LegacyAuthProtocolsEnabled $true

Updating your SharePoint Online tenant settings does not take immediate effect. So you need to wait a while, it can take up to 24 hours.


Cannot login to configure accounts
#3

Thanks Roman, that was the problem.

Note this also stopped actions from the Plumsail Workflow Action pack from working. This was difficult to diagnose, as the system tried to write the error to the workflow history log, but failed as the error message was too long (maximum length 255 characters).

This presented as an ‘Invalid Text Value’ error, rather than an authentication error.

Thanks again.


#4

Hi @gizmo3k!

Thank you for additional information. We will consider this.