First time use Provision PnP Template error


This is the first time I use Plumsail and want to test befor buying if it can do what I need.
There is the action Provision PnP Template that I try as in the documentation, but got the error below when running the workflow:
Identity Client Runtime Library (IDCRL) did not get a response from the Login server.

Hello Robert!

I believe you use a custom credential API key. If MFA is enabled for the account you used for the key generation, you need to re-create it using an app password and then update the connection in Power Automate. Perhaps, there are other security issues that prevent legacy authentication on behalf of your account. In this case I would advise switching to the admin permissions key.

Hi Evgeniy,

I tried that, didnt worked. Only works with admin sign in, but I cant use that in real life scenario.
Also the generated site from the template is without Title and the navigation is hidden, if I apply directly with PowerShell I dont have these issues. I think the connector needs to be fixed/updated.

Robert, could you confirm that the legacy authentication is allowed in your tenant? You can check it: try to authenticate with your account and an app password in some mail client, for example in Thunderbird. If it does not work, there is an issue with your security settings. If it does, please ensure that there is no error with the Actions API key: delete all the keys, generate a new one with the app password, delete all the Actions connections in Power Automate and create a new one with the newly created API key. Also, please check the version of the template engine: it should not be newer than 202209.

If you checked it all and it still does not work, please send a message to with your template file and raw inputs and outputs of the failed action. In the message, refer to this topic.