Item Limit Threshold - My Tickets View

Hi, one of the engineers is getting the error but if we goto all tickets and filter by new, in progress and @me it shows his tickets without issue.

He is the only one with the error


Hello Paul! Please go the the settings of the 'Tickets' list and open the 'My tickets' view:

There you can find the settings of the item limit, here is a default configuration that should work for you:

Sorry for the delay in response.

That is already set to what you suggested. The engineer had only 4 tickets assigned to them, like i said no other agent has this issue.

Happy to do a Teams if you want.


We have found that indexing fields helps to overcome the threshold problems.

I would agree, but why would it only affect 1 person out of 8?


Paul, please contact [email protected] and refer to this topic. In your message, please share the screenshots of the indexed columns and of the 'My tickets' view's settings. Also, ask the engineer to load HelpDesk in incognito mode, open developer tools (F12), switch to the ‘Network’ tab and reproduce the issue. Then export a HAR file:

Switch to the ‘Console’ tab, open the context menu of any record and save the logs:

Include the collected data into your message.

Email Sent to Support.