Org chart is not loading up in chrome browser


I’m using plumsail org chart version which was release at May 2018 within my SharePoint online tenant and its working fine when I am using Internet Explorer

But when I visit the page using Google chrome browser, the web part throws different errors that are mentioned below and does not load up. Sometimes it is stuck on the loading screen with Error No. 2
I’ve kept all the default settings and tried changing the data source as well. This issue is faced by some team mate’s but others don’t.

Also, I tried clearing my browser cookies and cache but the issue started appears again after some time.
Kindly provide your assistance as early as possible

Error 1:
The class for web part WebPart.PlumsailOrgChartWebPart.g_b32d091c_a9f2_4723_b34d_7af046b94a92,_internalInitialize is missing an expected member ‘{1}’.
at t [as constructor] (
at new t (
at Function.t.createWithLogProperties (…)
at e._instantiateWebPart (…)
at e._initializeAndRenderWebPart (…)
at …

Error 2:
Uncaught DOMException: Failed to execute ‘setItem’ on ‘Storage’: Setting the value of ‘PochGroupItemsCache_g_23842173_dbb2_4094_a5d9_0129e706e642’ exceeded the quota.

Thanks & Regards,

Hey Team,

Same for this one. Please any update will do


Hello @Kailash,

I am posting here the summary of the screen sharing session, so that other clients could learn about potential solutions.

  1. The issue with loading web part when a masonry script is on the page.

We assume that error in this script interrupts code of standard MS code that is loading our web part. Our web part is implemented based on Microsoft client-side framework called SharePoint Framework. The process of loading web part based on this framework is following:

  • Microsoft code shows the loading message
  • Microsoft code loads our scripts
  • Microsoft code calls our scripts to start web part rendering
  • Our code renders Org Chart

Most likely some conflict between MS code and masonry script interrupts loading this process on the first three steps.

We recommended you to try to use another script instead of masonry.

  1. The issue with insecure scripts loading.

There is your script loaded from http. Most likely Chrome interrupts loading of this script and then it breaks loading of our scripts.

We recommended you to use https protocol instead.

Please, do not hesitate to contact us anytime if you have any questions.

Best Regards,
Anna Dorokhova
Plumsail Team