Problem with numeric field


Since few days, a numercial SharePoint field stopped to work.
When I validate the form returns " Only number is allowed here" but I fill the field with numerical charateres

This field in SharePoint accept only integer
What is the problem ?

Hello @bsteam,

We've recently updated both Number and Currency fields, possibly the update caused this.

Please try to re-add the number field to the form and publish the form. That should resolve the issue.


It was my first action before post this message. this dont resolve the problem

I did other test and no problem with a number with 3 digits (under 1000) with 4 digit impossible to save the form

Hello @bsteam,

Do you have any custom code in the form? Please comment it out and check if the issue still persists.

Do you get the same error in all forms or just in this one?

All forms have this issue even this without code

just 3 digit = OK

More = KO


Could you please share the General settings of the nombre field.


By default , I have the problem

and with this change too, I don't find the good configuration


Format specifies displayed number format. For instance, if you want to display the number with 2 decimals (125,25), the format should be set to n2. Please find more examples here.

Decimals specifies the number of precision applied to the field value.

You can find more information about the unique properties of Currency and Number fields here.

Regarding the error, there are no properties that can throw the error.

Please try to completely clear the browser cache and test if the error persists.

Also, please check the app version in the console (F12). The latest version is 1.0.7. If the latest version not installed, please follow the instructions on how to Update the app package.


Yes I have the last version, but I prefere to come to a version without problem.

With the format N always the same problem


Could you please share the screenshot of the regional settings page. Go to Site Settings >> Site Administration >> Regional settings.


The issue occurs for some languages only, including French (Switzerland). We've started to work on a fix.

And for now, please switch to French (France) or French (Belgium) language to work with Number field.

I will let you know once we resolve the problem.

Its ok in French France, when the correction for ch-fr ?


We are already working on a fix. I will let you know once we publish it.


I have an another problem with the numeric field, with this code
fd.field("PJ").disabled = true;

my field is enable now

Hello @bsteam,

We've published the fix of this problem a few days ago.

Please completely clear the browser cache and test if you can disable the field using this code:

fd.field("PJ").disabled = true;
1 Like

Hello @bsteam,

Could you please temporarily switch back to French (Switzerland) and provide the screenshot of the Currency/Number column data as you see it in the list view.

We need to check how the numbers are formatted on your tenant. Seems that formatting for this language has been changed recently, and not all tenants were updated.

Hello Nikitina,

We have exact the same problem, but for nl-be (Dutch - Belgium). Can you (ask to) fix this?

Thank you,


Hello @danieljr,

Thank you for reporting this!

I've passed the information to the developers. I'll let you know as soon as a fix is published.