Triggers on "Ticket has been changed" not working anymore

Hello. We have noticed all triggers fired on "Ticket has been changed" condition do not work anymore.
Here's an example:

The problem is not on SMTP server, since even if I add "set field Title to" on "Actions to perform", it doesn't work. And all other triggers' notifications work: as said the problem is only on "Ticket has been changed" triggers.
Log is seems last one was fired on a "null" ticket, could that be the problem?
We run version 1.4.6 of the app.

Hello! Please send me via private message your SharePoint domain and the ID of the ticket which was modified recently and supposed to fire the trigger. According to the logs on the screenshot, the trigger didn't work since May 2020, didn't you use HelpDesk all that time?

Thank you for the provided information. Could you also create a new trigger from scratch and check whether ticket modification fires it? It will help in researching the issue.

Hello, done. I've created a new trigger, identical as the one above, except "Order" and "Actions to perform": instead of sending email I've put a "Set field Piority to Low".
As soon as we change a ticket, I'll check whether it works and let you know.

You can create a test ticket and work with it not to wait for a real case when you had to modify a ticket.

Hello, I've tried, it doesn't work.
I even removed from the new trigger, all trigger conditions except the first one: Ticket.AssignedTo.ID not equal to [empty]; tried again, doesn't work.
Then I've removed all trigger conditions: doesn't work.
So it seems the problem is on the "Execute when" condition: if set to "Ticket has been changed", trigger doesn't start, regardless of trigger conditions or trigger actions.

I have passed the information on the issue to developers for researching.

Is it appropriate for you to update HelpDesk to the latest version with modern SharePoint UI? It is very likely that it will solve the issue. If it is alright, please update your instance, clear browser cache and let me know about results. Otherwise, it will require a while for researching.

Solved, after updating to 2.1.13

1 Like