Org chart gets stuck on spinning wheel unless page is refreshed


#1

I’m having problems with the org chart not loading in Sharepoint 365

In the vast majority of cases users get the outline grey box and spinning wheel but the org chart refuses to load.

If the page is refreshed it then loads fine almost immediately.

This is happening on all pages that use the org chart plugin - regardless of whether the whole tree is being displayed or a limited department subset.

What can I do to fix this? My end users just assume the org chart is broken as it never loads.


#2

Hi @ian,

Thank you for your message.

First of all try to clear Org Chart cache and browser cache.

If after this the issue persists, open developer tools of your browser (F12), navigate to “Console” tab, reproduce the issue and send us a screenshot of the “Console” tab and of the web part.

This will help us to research the issue better.


#3

Hi @antonkhrit

Many thanks for your response. I’ve attached a screenshot and some of the error messages that show in Console (I have reset the cache).

I’ve also attached a second screenshot showing after the page is refreshed. Interestingly the same sort of error messages appear in console on the second successful run.

There’s a lot more detail in the console tab than I can show in the screenshot - please let me know if you need this.

Thanks!

Screenshot 1 (failed load)|690x365
Ian


#4

Failed load screenshot:


#5

Hi @ian,

Yes, please send us complete log. You can save it by right click -> Save as:
image

Additionally, please ensure, that there is just a single Org Chart web part on a page.


#6

Hi @antonkhrit

OK - I’ve now got the two logs - the first is when the page first opens and the org chart fails to load. The second is when the page is refreshed and loads successfully. There is only a single org web part on the page.

However this forum won’t let me attach files as it says new users aren’t allowed to upload files. Would you be able to change that setting or give me an email address to send them to.

Many thanks


#7

Hi @ian,

We have increased the limit. You also can send them to [email protected] with the link to this conversation.


#8

We are experiencing this exact same scenario. Was there ever a resolution?


#9

Hi @MarcLaf,

Usually it is related to custom master page and some third party scripts breaking standard SharePoint Framework web part loading.

If you use custom master page, try to create a new site with a standard master page and try to reproduce the issue there.


#10

Hi @antonkhrit

We have not changed our master pages or are using any other third party script / plugin on our site. The issue happens on multiple sites (even newly created ones).


#11

@antonkhrit I may have spoke too soon. We had some interns working on our SharePoint deployment over the summer and they may have made modifications to the master pages because when I run health checks on the site collection, I get a warning that the home pages have been modified.

If I try to reset the page using the link included I get redirected to a page that says I don’t have permission (I am the tenant admin). This site is a brand new site as well so I’m wondering if it’s inheriting anything from the top? I feel that this issue is far out of scope for this particular support forum…

Consider fixing the following problem(s) either before or after upgrading:
Customized Files

The following files have been customized from their default and may present some unexpected visuals or behavior after upgrade:

Reset specific pages to default to make the page lose customizations and any embedded data. Normally, you should do this only if you are having difficulty using the page after upgrade.


#12

This is happening to us in our tenancy - none of our sites have had master pages modified.

We’ve upgraded the webpart to the latest version, tried it on several sites - even brand new sites within the tenancy and we’ve also tried this web part on a Modern page with no modifications and the same still happens.

Any update on what may be doing this?


#13

Hey suvvers,

We currently have support looking into it. If and when they come back with a resolution I’ll post here if it’s applicable to everyone.


#14

Is there any update on this? I have a customer seeing this same behavior.


#15

Hello @cchandler,

Does your customer have an issue with Org Chart loading? Could you please, navigate to the page with Org Chart, open developer tools of the browser (F12), navigate to “Console” tab, reproduce the issue and send us a screenshot of the “Console” tab and of the web part. You also can send it to [email protected] with the link to this conversation.

Please, click the Gear button in the top right corner of the chart, then click Help, take a screenshot of the popup window and send it to us as well.

Please let us know if your customer made any modifications to the master page.

Also please try to create a new empty page, add there an org chart with the default settings and check if it works. Please, let us know about the results.

Anna Dorokhova


#16

Hi @Anna, see below


#17

Hello @coresoul,

I assume you posted this screenshot as an answer to this message Org Chart Loading super slow?

Could you also please provide information regarding the other questions? It would help us to understand what can be the issue. Could you also please send us a screenshot of the Data Source Settings and General Settings tabs of the Configuration Wizard?

Best Regards,
Anna Dorokhova
Plumsail Team


#18

Hi

Has there been any more information given on what may be causing the slow down in loading?


#19

Hello @suvvers,

We investigated the issue with initial loading of Org Chart and released a new version with a fix for it. We are waiting for information from a client whether everything works fine now. I will post an updated once we have a confirmation.


#20

We are having this issue as well when will a new version be released?