The sign-in name or password does not match one in the Microsoft account system

I have a flow that Invites External Users to a Sharepoint site with the Plumsail connector. Yesterday, I had to change my Office365 password. This caused several failures within flow, but all of them revealed themselves pretty readily and I was able to fix them without any issue. However, the plumsail connector continues to fail and I keep getting the error message "The sign-in name or password does not match one in the Microsoft account system." I assume that this is a result of the password change yesterday, but I cannot find anywhere to enter the new password and fix the problem. My password is correct on Sharepoint, its correct in Power Automate, its correct in Outlook, its correct everywhere that even remotely touches this flow. But I continue to get the error. If anyone can offer help, I would appreciate it as there is urgency to fixing this issue ASAP.

I was able to fix this problem by creating a new API key.

But now I have a new problem. I get an error saying "The user has insufficient permissions to create an invitation." I have no idea how to fix this. Any advice is appreciated. This has brought a very important workflow to an absolute standstill.

It appears that the flow works for existing guest users, but not for new external users.

Hello! Please try to use an admin permissions API key, specify your SharePoint domain when creating it and let me know whether it works:


As I understand, currently, you use the custom credential API key. Using the same account as when you created it, are you able to invite external users to the same site manually? Please check it on the same site as in the flow and both for existing and new external users.

Evgeniy - I attempted to respond to you via email but it bounced back as undeliverable. I have tried an admin API key AND a credential API key – both created after I changed my account password – neither works. Below is the content of an email I submitted to Plumsail support that describes the issue in more detail. I have received no response from the Support Ticket email so hopefully this will be more successful.


I have a few flows that are designed to send access links to external users for various sharepoint sites. Most urgently, one of those sites contains On-Demand education courses for a virtual conference my company is currently hosting. The flow worked perfectly for about 3 months until Wednesday 2/17 when I was forced to change my Office password. Upon changing the password, flows using this connector began getting the following error message: "The sign-in name or password does not match one in the Microsoft account system."

I then created a new Plumsail API Administrator-key and attempted to use that, but that did not work either and resulted in a different error message: "The user has insufficient permissions to create an invitation." This error was very unusual as I am the global administrator for our environment AND still have the ability to manually invite users to the sharepoint site. Only the flow does not function.

I then created another Plumsail API Credentials level key tied directly to my email address. That did not work either and resulted in a third error message: "AADSTS50034: The user account (Email Hidden) does not exist in the ride training.onmicrosoft.com directory. To sign into this application, the account must be added to the directory." This error made even less sense than the prior error as my user account absolutely exists in the ridetraining.onmicrosoft.com directory.

At this point, this error with the Plumsail connector has caused significant business interruption and is preventing clients from accessing information from our company. I have been on the phone with Microsoft support for more than 6 hours over the last few days, but no one there seems able to solve the issue (although they are continuing to try). I require immediate assistance in fixing this problem. Please contact me as soon as possible.

Erik, I have assigned the tickets you submitted to me and passed the information on the issue to the developers. I have reproduced it with an admin API key, but the custom credentials one works fine. While they research it, could you specify the following:

  1. Please open SharePoint admin center and take screenshots of access control settings, provide me with them in the ticket you opened.


  2. Also, please share the external sharing settings of your site:

  3. Is it possible to create a test site in your environment and a temporary account (site owner) to provide us with its credential? Researching the issue in your environment could speed up the research.

  4. Please ensure that you disabled MFA, used your full e-mail when created an API key ([email protected], not [email protected]) and a proper password. Try to use your credentials to log in to the site first, if they worked, create another API key and use it in your current connection. If the MFA is enabled, use an app password.

  5. Please check whether any security policies or settings were changed when the issue occurred: in SharePoint, Microsoft 365, Azure AD admin centres or elsewhere.

Let's continue the further discussion in the submitted ticket. The results will be published in this thread.