Unable to Invite new user to group


I have a one action flow that invites external users to a SharePoint group. It works if the user previously exists as an external user but not if they are new users unknown to the tenant. I have tried with a connection using [email protected] and [email protected] both with the same result.

I get the error - AADSTS50034: The user account {EmailHidden} does not exist in the domain.onmicrosoft.com directory. To sign into this application, the account must be added to the directory.

I can manually add an external user if I'm signed in with the admin account so the functionality is working and the permissions good.

This looks like a duplicate of The sign-in name or password does not match one in the Microsoft account system but I can't see a resolution in that post.


Hell Marshall!

The error usually occurs when you use an e-mail instead of a user principal name to log in, that is [email protected] instead of [email protected]. But you say that you took it into account when created the API key. I would advise to try another its type - one with admin permissions. It may be the fastest solution of the issue. If you wish to research the issue with the custom credential API key, please reproduce it. Then, open the sign-in logs in Azure AD and find the failed authentication attempt:

Open it, take screenshots of each tab except the 'Location' and 'Device info' ones. All the provided information should be visible. Then send the files to [email protected] and refer to this topic.