Update SharePoint Group Properties failing randomly

Good afternoon,

I ran into an issue recently using the action mentioned on the title.

Upon running this Plumsail action it fails from time to time. I cannot precise its behavior. The scenario is the following:

  1. Create a Sharepoint site group.

  2. Update its properties including the owner of said group. This owner is always the same.

  3. Repeat the process for each site group needed for the solution.


All this is encapsulated in an for each loop. Sometimes it works, sometimes it fails. For example, it works for the 1st to the 5th iteration, fails on the 6th to the 11th iteration, works on the 12th iteration, fails for the rest.
When it fails the error is the following:


The username mentioned corresponds to the Owner field and it's a group. It exists otherwise it wouldn't only fail from time to time.

Could you please look into this issue and help me understand this behavior, as well as come up with a solution?

Thank you for your time,
João Oliveira

I've tried the same actions in "Do until" loop, it had 19 iterations, the flow ran several times and I couldn't reproduce the issue.

Could you try adding of a delay before the "Update SharePoint Group," I'd say 30 seconds for beginning? Perhaps there are too many requests and they are too frequent and that leads to the error. Also, try the delay with another your flow where you check whether a user is a member of SharePoint group.

Also, I would ask you to open a support ticket - send a message to [email protected] and attach screenshots with configuration of both your flows (all actions with opened properties) and with input and output of failed actions.

Hello, João.

After I had informed you about fixing the action "Is User Member of SharePoint Group", did you encounter the issue from this topic? Or does it work fine now too?